We have identified the issue to be related to PSPs running under AWS. As the error rate has remained at healthy levels for the last 30 minutes we consider this incident resolved.
Posted Mar 18, 2025 - 21:00 UTC
Monitoring
The error rate has returned to regular levels. We are no longer observing timeouts. We will continue to monitor the health of transactions and stay in contact with our upstream provider.
Posted Mar 18, 2025 - 20:42 UTC
Update
Our ISP has further escalated the issue to isolated the bad network hop. The error rate remains stable but impact remains low.
Posted Mar 18, 2025 - 20:37 UTC
Identified
We have identified the issue to be a routing issue. We are in contact with our upstream network provider to reroute the affected traffic.
Posted Mar 18, 2025 - 20:04 UTC
Investigating
We have noticed intermittent timeouts in incoming traffic impacting a small subset of transactions. We are investigating the issue.
Posted Mar 18, 2025 - 19:50 UTC
This incident affected: Transaction Processing and Credit card Processing.