Important Information: Support Contact
Incident Report for IXOPAY
Resolved
The Issue is resolved, our support number is reachable again. Please escalate urgent matters via phone again.
Posted Mar 11, 2024 - 06:02 UTC
Identified
We are currently experiencing technical difficulties with our support telephone number. Our provider is working on a resolution. Meanwhile, please send urgent matters via a ticket to support@ixopay.com, which is monitored 24/7 by our team.
Thank you for your understanding and cooperation.
Posted Mar 11, 2024 - 05:01 UTC
This incident affected: Support Phone Number & Email.