Issues with EU customer support phone line

Incident Report for IXOPAY

Resolved

We are pleased to confirm that the functionality of the EU Support Line has been restored. Our team has verified the fix, and the incident is resolved.
Posted Jan 16, 2026 - 11:32 UTC

Identified

The issue has been identified, and we are currently working on a solution. In the meantime, if you require urgent assistance, please use our preliminary EU support phone line at +43 1 353 05 05-4567.
Posted Jan 09, 2026 - 21:42 UTC

Investigating

We are currently experiencing issues with our EU support phone line (+43 1 353 05 12-247). We have contacted our telephone provider, and they are investigating. In the meantime, please use the support portal to submit tickets.
Posted Jan 09, 2026 - 17:15 UTC
This incident affected: Support (Support Phone Number).