Payment Orchestration Service Disruption

Incident Report for IXOPAY

Identified

Our teams are continuing to work on resolving the issue. We will provide further updates as they become available.
Posted Jun 19, 2026 - 11:08 UTC

Investigating

We are currently experiencing a service disruption affecting Payment Orchestration. Teams are engaged and actively investigating. Further updates will follow as more information becomes available.
Posted Jun 19, 2026 - 09:36 UTC
This incident affects: Payment Orchestration (Transaction Processing API, Tokenization Service, 3-D Secure Engine, Hosted Payment Pages, BI Data Source, Admin UI, Dashboards, API Documentation, Test/Sandbox Environment).