Elevated Google Pay Error Rate
Incident Report for IXOPAY
Resolved
Services are stable. We have not observed any more errors since 19:15 UTC.
Posted Oct 11, 2023 - 21:24 UTC
Monitoring
The external issue seems to have resolved at the moment.
Our teams are continuing to monitor the transaction processing closely at this point.
Posted Oct 11, 2023 - 19:58 UTC
Identified
We have identified external technical issues with Google Pay.
We'll post updates, once Google Pay has recovered.
Posted Oct 11, 2023 - 19:00 UTC
This incident affected: Credit card Processing.