Issues with US customer support phone line

Incident Report for IXOPAY

Resolved

Our US support phone line (1-877-217-5718) is now fully operational. Thank you for your patience while we worked with our provider to restore service. We’re sorry for any inconvenience this may have caused and appreciate your understanding
Posted Jan 07, 2026 - 02:09 UTC

Investigating

We are currently experiencing issues with our US support phone line (1-877-217-5718). We have contacted our telephony provider, and they are investigating. In the meantime, please use the support portal to submit tickets.
Posted Jan 06, 2026 - 18:49 UTC
This incident affected: Support (Support Phone Number).