Elevated rate of unauthenticated 3DS transactions
Incident Report for IXOPAY
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 13:45 UTC
Investigating
We're investigating an elevated rate of unauthenticated transactions in context of 3DS v2 challenges.
Posted Jun 14, 2021 - 13:39 UTC